Java от Sun (Oracle) в Ubuntu 10.04 Lucid Lynx в Firefox

Java от Sun (Oracle) в Ubuntu 10.04 Lucid Lynx

После обновления ubuntu до версии 10.04 (lucid lynx) перестал работать java plugin в firefox. Ранее у меня был установлен openjdk, но судя по форумам он работать не будет. Следовательно нужно вернуться к sun jre.

Также читаем о других проблемах, возникших после обновления ubuntu до lucid lynx.

Сейчас же проделаем несколько нехитрых операций:

  • удалим openjdk. Нашли пакеты, в названии которых есть openjdk и вынесли из системы.
  • раскомментировать строки в файле /etc/apt/sources.list.
    # deb http://archive.canonical.com/ubuntu lucid partner
    # deb-src http://archive.canonical.com/ubuntu lucid partner
  • устанавливаем:
    sudo aptitude update
    sudo aptitude install sun-java6-jre sun-java6-fonts sun-java6-plugin
  • создаем символическую ссылку, чтобы сообщить firefox о необходимости использования именно этого плагина: sudo ln -s /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/
  • перезапускаем firefox и проверяем версию используемого плагина по адресу about:plugins

Удачи!

вернуться назад